Enrutamiento OSPF


La presente práctica es sobre enrutamiento dinámico OSPF, para esta se tiene una red con tres (3) áreas a configurar como se muestra en la figura siguiente:



En la figura se han detallado las Aras a configurar, las direcciones IP asignadas a las subredes son las mismas en el área 1 y área 2 como se puede observar. Esto se hizo así ya que en la configuración de los routers se ha determinado el área que va a cubrir para cada red por tanto los routers del área 1 no tendrán nada que ver del área 2; es decir la configuración de las direcciones IP se realizara por áreas con lo cual una IP de un área no interferirá o habrá duplicación de direcciones IP ya que los routers las ven en áreas distintas.




COMANDOS UTILIZADOS
Router>enable
Router#configure terminal
Router(config)#hostname Router1
Router1(config)#
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ip address 192.168.0.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#interface Serial1/0
Router1(config-if)#no shutdown
Router1(config-if)#ip address 192.168.6.1 255.255.255.252
Router1(config-if)#clock rate 64000
Router1(config-if)#exit
Router1(config)#interface Serial1/1
Router1(config-if)#no shutdown
Router1(config-if)#ip address 192.168.7.1 255.255.255.252
Router1(config-if)#clock rate 64000
Router1(config-if)#exit
Router1(config)#router ospf 1
Router1(config-router)#network 192.168.0.0 0.0.0.255 area 1
Router1(config-router)#network 192.168.6.0 0.0.0.3 area 1
Router1(config-router)#network 192.168.7.0 0.0.0.3 area 1
Router1(config-router)#exit
Router1(config)#exit

Después de haber configurado las interfaces se configuro el enrutamiento OSPF, se utilizó en todos los router el identificador de proceso 1; nótese que en este router todas las redes pertenecen al área 1 por tanto se configuraron con esa área. La máscara de wildcard para las direcciones de red de los enlaces seriales es 0.0.0.3 ya que se usó mascara 255.255.255.252.



Router1(config-if)#show ip ospf database
Con este último comando se verifica la configuración ospf en el router, la base de datos para la configuración de este.


Se puede observar que con este comando se muestra la ID del router y el numero asignado del proceso (proceso 1 que se configuro), asi mismo muestra las direcciones de red configuradas por ospf la secuencia de actualización de la tabla lsa y demás información necesaria.
Router1#show ip route






Con este comando verificamos como se ha configurado el enrutamiento en el router, las redes conectadas directamente aparecen con la letra C, las que se han actualizado por ospf con una letra O. Con este comando se puede verificar la dirección de Red configurada, y la máscara, la distancia administrativa que para ospf es 110 y la métrica, que para el caso ospf es el costo que tiene que ver con el ancho de banda en el enlace. También se muestra el tiempo de actualización de la base de datos las que para ospf predeterminadamente es 30 minutos cada actualización; por ultimo verifica el serial por el que se establece la comunicación.
La misma configuración se utilizó para los demás routers teniendo cuidado al momento de configurar ospf tener en cuenta el área que va a tener cada dirección de red, de lo contrario tendremos problemas en nuestra configuración de red.



ROUTER 2
Router>enable
Router#configure terminal
Router(config)#hostname Router2
Router2(config)#interface FastEthernet0/0
Router2(config-if)#ip address 192.168.2.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#interface Serial1/0
Router2(config-if)#ip address 192.168.6.2 255.255.255.252
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#interface Serial1/1
Router2(config-if)#ip address 192.168.8.2 255.255.255.252
Router2(config-if)#no shutdown
Router2(config-if)#exIT
Router2(config)#router ospf 1
Router2(config-router)#network 192.168.2.0 0.0.0.3 area 0
Router2(config-router)#network 192.168.6.0 0.0.0.3 area 1
Router2(config-router)#network 192.168.8.0 0.0.0.3 area 1
Router2(config-router)#exit


Después de haber configurado las interfaces de comunicación de los routers se configuro el enrutamiento dinámico por ospf, la primera red que se configuro es la que conecta con el switch entre las dos áreas, esa dirección de red pertenece al área cero (0) por tanto se configuro, las demás redes pertenecen al área uno (1), se puede observar esa configuración en los comandos.



La configuración de los demás routers es la misma solo cambian las áreas por tanto se especificaron en este pre laboratorio solo dos routers con los comandos utilizados.
Las asignaciones de las direcciones IP de las maquinas fue como se explicó anteriormente la misma, pues estas están en áreas distintas con lo que los routers no detectaran direcciones duplicadas en la red.









Compartir: Compartir

Publicar un comentario

DUDAS SE ACLARAN EN EL FORO TEMÁTICO

 
Copyright © 2011. Libros, Simuladores, Tutoriales Y Mucho Más - All Rights Reserved